Breville Barista vapor locked? How do I fix that?

I have a Breville Barista and it has generally met my expectations for coffee. Lately I noticed the pressure on the meter going down, to a point where the needle hardly moved (about 8 o’clock on the meter) during the brewing process. I opened the machine and inspected the solenoids. They seemed to be OK (the slugs inside moved without noticeable resistance and were clean, as was the whole solenoid assembly). So I ordered a new pump and put that in. It did not make a difference. I tested the pressure with the rubber insert for cleaning and no coffee, and the pressure shot up to full scale (about 2 o’clock on the meter). But still no pressure when brewing, in fact, now I don’t seem to be able to create any pressure at all. I can get steam out of the steam wand, the hot water nozzle delivers water and steam, but only sputteringly, The brew head delivers maybe a few drops of water and a bit of steam.
I had this on the same machine a couple of years ago, and. being under warranty, Breville fixed that at no charge, but never told me what the problem was.
Looking through a bunch of posts, it looks to me as if the unit is vapor locked, but I can’t find anything that would help me rectify that. I tried to use a turkey baster to gently push water into the pump, but that didn’t help.
I also tried multiple times to prime the unit by running water through the steam wand, but I am not sure if I do that right. I can’t find any good description how to do that on the BES70XL. I would guess that there should be a way to pump water into the whole system (including boiler) without heating it, as the the air in the boiler would expand and prevent the pump from delivering water into the boiler.
Any suggestion what to do next?