Help! Black Eagle VA388 low group temp issue


I run a two group Black Eagle VA388 and this morning my groups were giving me a ‘low’ temperature reading. They were both warm but nowhere near as hot as they should be. I ran both groups for a few minutes to see if that helped - and it did a little. Instead of reading ‘low’ it was now giving me an actual temperature for each group… But as soon as I stopped running water it would slowly drop back down to ‘low’.

Usual temp for each group is set to 92.8°C but running the groups for a few minutes only got them up to around 75°C… Nothing’s been changed or tampered with in the settings. Air con was off over night, no drastic changes in weather or external temperature …

Only guess is that it’s some kind of internal temperature probe issue (as the machine is left on 24/7). Basic ware and tare.

Has anyone experienced anything similar or have any ideas as to what might be up? I’m back in the cafe later tonight to see if I can do anything so any help is much appreciated :smile:



Could be a few things-

Check the alarm/error messages in the programming settings
Check scale build up on your probes
Check current to elements
Try turning it on and off again if you haven’t already.
It could be a problem with the board but this is unlikely.

I hope you’ve got this resolved.


Good to see you on here Andrew :+1:t3:

Have done all of the above twice and both times it started working again for 2-3hrs before suddenly losing temperature again.

Playing around with the board is beyond me (also really hoping it’s not the board) but will make more calls and see who knows what. Hoping it’s scale … But scale on a 5 month old machine being fed with a brand new RO feels highly unlikely.

Know any good Black Eagle techs in London?

Maybe speak to VA Machinery ( and see who they recommend? I know a good VA tech in Glasgow but the call out fee for that one might be prohibitive…